Быстрый поиск
Russia Ukraine Belarus Israel Turkey Lithuania Latvia Estonia Mongolia Moldova Armenia Kazahstan Georgia
Вопрос: Как настроить DHCP relay на коммутаторе DGS-1510 при использовании нескольких VLAN через CLI?

Ответ: 

VLAN 1 подсеть: 192.168.1.0/24
VLAN 10 подсеть: 192.168.10.0/24
VLAN 20 подсеть: 192.168.20.0/24
DHCP-server: 192.168.1.100

Создаем VLAN 10, 20 и IP-интерфейсы для добавленных VLAN. В этом примере мы назначаем подсеть 192.168.10.90 во VLAN 10, 192.168.20.90 во VLAN 20.

Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.90 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.20.90 255.255.255.0
Switch(config-if)#exit

Добавляем порты в созданные VLAN. В этом примере порт 7 добавляется во VLAN 10, порт 8 добавляется во VLAN 20, а DHCP-сервер будет подключен в порт 24, находящийся во VLAN 1.

Switch(config)#interface ethernet 1/0/7
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface ethernet 1/0/8
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface ethernet 1/0/24
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1
Switch(config-if)#exit

Включаем DHCP relay, определяем пулы, адреса источников и адрес DHCP-сервера. Адреса источников - это IP-адреса, созданных на коммутаторе интерфейсов, для VLAN, где будут клиенты, получаемые адреса по DHCP.

Switch(config)#service dhcp
Switch(config)#ip dhcp relay information option
Switch(config)#ip dhcp pool corporate
Switch(config-dhcp-pool)#relay source 192.168.10.90 255.255.255.0
Switch(config-dhcp-pool)#relay destination 192.168.1.100
Switch(config-dhcp-pool)#exit
Switch(config)#ip dhcp pool guest
Switch(config-dhcp-pool)#relay source 192.168.20.90 255.255.255.0
Switch(config-dhcp-pool)#relay destination 192.168.1.100
Switch(config-dhcp-pool)#
Switch#copy run start
Destination filename startup-config? [y/n]: y
Saving all configurations to NV-RAM.......... Done.

Проверяем, что клиенты получили корректные адреса.

Продукты и решения | Поддержка  | Новости  | О компании |